RMG 280DL works with 75 mhz but not Spektrum 2.4

Radios, Servos, Winches, Batteries
All things that can make sparks

Moderators: Capt. Flak, bigfoot55, Chuck Luscomb

RMG 280DL works with 75 mhz but not Spektrum 2.4

Postby s vernon » Tue May 01, 2012 11:51 am

Getting my Carl Olbrich replica boat ready for the opening regatta. It has always been on 75 mhz. I am switching over to my Spektrum system. RMG 280DL. Works fine on 75 mhz with a Skysport or a Hitec 3 channel.

It will not work with the Spektrum. I have the cut red wire mod done on it. Rudder and jib trim work fine, No movement or noise from the RMG.

I put it back on the Hitec and it works fine as expected.

I put another cut red wire mod RMG 280DL in the boat and it works fine with the Spektrum radio system as expected.

So I am good to go. I just wonder what might be done to make it talk with the DX6i. What does it care what system it is hooked up to? I have always done the orignal fireup on RMGs using a Skysport since it is a simpler process with the older RMG models. Then when I plug the RMG into the 2.4 rcvr and sail the boat there has never been a problem.
Scott
User avatar
s vernon
 
Posts: 471
Joined: Mon Sep 15, 2003 9:18 pm
Location:

Re: RMG 280DL works with 75 mhz but not Spektrum 2.4

Postby Tim » Tue May 01, 2012 12:25 pm

Scott,

That is the exact combination I am using with no troubles at all. In fact I now have a backup 280EL and swap back and forth with my primary unit 280DL with no issues using a Spectrum Dx6i.

Good luck.
Tim
Vermont
"Just for Fun" #484
Tim
 
Posts: 46
Joined: Tue Feb 05, 2008 12:21 pm


Return to Electronics

Who is online

Users browsing this forum: No registered users and 0 guests

cron